FlexSEA Wiki

A WEARABLE ROBOTICS TOOLKIT

User Tools

Site Tools


ubuntudeveenvironment

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

ubuntudeveenvironment [2019/03/07 23:01] (current)
dtscbs created
Line 1: Line 1:
 +==== Ubuntu Development Environment ====
 +
 +The standard install for Linux development is Ubuntu <​del>​16.04</​del>​ 18.04 LTS. This can be downloaded from <​del>​[[http://​releases.ubuntu.com/​16.04/​|Ubuntu 16.04 LTS]]</​del>​ [[http://​releases.ubuntu.com/​18.04/​|Ubuntu 18.04 LTS]]. A virtual machine can be created using [[https://​www.vmware.com/​products/​workstation-player.html | VMWare Player]]. After installing VMWare Player and Ubuntu, ​ You will have to install the following packages to develop software on the VM.
 +
 +  * git
 +  * cmake
 +  * gcc
 +  * g++
 +  * python
 +  * vim (or the editor of your choice)
 +
 +<​code>​
 +sudo apt-get update
 +sudo apt-get install git cmake vim
 +sudo apt-get install gcc g++
 +sudo apt-get install python
 +</​code>​
 +
 +
 +GCC/G++ version for 18.04 defaults to 7. Dephy users are running version 6. To install, perform the following steps.
 +
 +
 +<​code>​
 +sudo apt-get install gcc-6 g++-6
 +</​code>​
 +
 +==== Configuring Ubuntu ====
 +The following should be performed to configure Ubuntu for ease of use:
 +
 +<​code>​
 +git config --global user.email "​you@example.com"​
 +git config --global user.name "Your Name"
 +
 +</​code>​
 +
 +==== Adding Qt to Ubuntu ====
 +
 +Download the Qt creator from the web. You can find it [[https://​www.qt.io/​download|here]].
 +
 +Install it by performing the following steps. You will need to create an account on the Qt web site.
 +
 +<​code>​
 +
 +pushd ~/Downloads
 +chmod +x qt-unified-linux-x64-3.0.6-online.run
 +./​qt-unified-linux-x64-3.0.6-online.run
 +popd
 +</​code>​
 +
 +The installer will download and install the software.
  
ubuntudeveenvironment.txt ยท Last modified: 2019/03/07 23:01 by dtscbs