FlexSEA Wiki

A WEARABLE ROBOTICS TOOLKIT

User Tools

Site Tools


pythonscripts2

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
pythonscripts2 [2020/04/08 20:26]
jfduval
pythonscripts2 [2020/07/10 18:34] (current)
bbaig [Python Interface 2.0 (Deprecated)]
Line 7: Line 7:
 These scripts are written in Python 3 and have been tested on Python version 3.7.3 and 3.6 32 bit and 64 bit (using Windows 10 Pro), as well as 32 bit Rasbian on a Raspberry Pi 3 and Ubuntu 18 64 bits. They do not seem to work with Python 3.8.1 on Windows. These scripts are written in Python 3 and have been tested on Python version 3.7.3 and 3.6 32 bit and 64 bit (using Windows 10 Pro), as well as 32 bit Rasbian on a Raspberry Pi 3 and Ubuntu 18 64 bits. They do not seem to work with Python 3.8.1 on Windows.
  
-The code is available at [[https://​github.com/​DephyInc/​Actuator-Package|Actuator Package]]. This git repository contains the API, DLLs, and example scripts. The functions are documented in pyFlexsea.py. Additional documentation on the fx_plan_stack API can be found [[build_fx_plan|here]]. +The code is available ​on GitHub ​at [[https://​github.com/​DephyInc/​Actuator-Package/|Actuator Package]]. This git repository contains the API, DLLs, and example scripts. The functions are documented in  ​[[https://​github.com/​DephyInc/​Actuator-Package/​tree/​master/​Python/​flexseapython|pyFlexsea.py]]. Additional documentation on the fx_plan_stack API can be found [[fx_plan_stack_api|here]].
 =====Converting from Python interface 1.0===== =====Converting from Python interface 1.0=====
 The new python interface addresses some short comings of the [[actpackpython|previous version]]. As the Python interface 1.0 is no longer supported, here is how to [[python_interface_conversion|port your existing code]]. The new python interface addresses some short comings of the [[actpackpython|previous version]]. As the Python interface 1.0 is no longer supported, here is how to [[python_interface_conversion|port your existing code]].
pythonscripts2.1586377608.txt.gz · Last modified: 2020/04/08 20:26 by jfduval